De installatie van Teach2000

Kies een van de volgende onderwerpen:
  • Systeemvereisten
  • Installatie
  • Teach2000 in een netwerk
  • Installatie ongedaan maken

terug naar start
copyright © 1997-2007 basement.nl / bas groot


Systeemvereisten

Om de software te kunnen draaien moet de computer minstens aan de volgende eisen voldoen:
  • Een computer met Windows 98SE of nieuwer.
    Sommige functies werken alleen met XP en Vista, deze zijn niet zichtbaar in Windows 98.
  • De processor moet een minimaal snelheid hebben van 120 MHz.
  • 64 MB RAM.
  • 15 MB vrije diskruimte.
Verder is het handig om te hebben..
  • Een geluidskaart om vragen af te spelen.
  • Een grafische kaart met 256 kleuren of meer voor de illustraties bij de vragen.
  • Een microfoon om vragen op te nemen.

terug naar start - installatie


Installatie

De installatiehandleiding is te vinden op internet.
Zie www.teach2000.nl.

Kies links in het menu voor Support - Installatie.
terug naar start - installatie


Teach2000 in een netwerk

Het is mogelijk Teach2000 in een Windows NT/200x/Novell-netwerk te installeren met centrale (server) opslag van de data/lijsten.

Hiervoor zijn alle bestanden nodig zoals ze ook in de installatiedirectory worden geïnstalleerd. Het installatieprogramma plaatst geen bestanden in andere mappen.

De t2k-bestanden (vragenlijsten) kunnen ook op het netwerk worden gezet.

Op iedere client-pc kan een snelkoppeling worden gemaakt naar Teach2000.exe op het netwerk.

Voor de techneuten

Om te zorgen dat bij het opstarten Teach2000 altijd dezelfde directory opent, moet een registry-setting voor de HKCU gepushed worden, HKCU\Software\Teach2000\MainForm\LastDirUsed. De value van deze key kan bijvoorbeeld naar een netwerkfolder verwijzen.
In dezefde registry-key moet dan ook RememberLastDirUsed de waarde 1 krijgen.

Als vervolgens ook het t2k-bestand met Teach2000 moet worden geassocieerd is een registry-wijziging nodig (in dit voorbeeld is Teach2000.exe te vinden in 'X:\Dirname'):

[HKEY_CLASSES_ROOT\.t2k]
@="Teach2000.Document"
[HKEY_CLASSES_ROOT\Teach2000.Document]
@="Teach2000 Document"
[HKEY_CLASSES_ROOT\Teach2000.Document\shell]
[HKEY_CLASSES_ROOT\Teach2000.Document\shell\open]
[HKEY_CLASSES_ROOT\Teach2000.Document\shell\open\command]
@="\"X:\\Dirname\\Teach2000.exe\" \"%1\""

Een overzicht van alle tijdens de installatie gedane acties kan worden gemaakt door de installatie op te starten met parameter /LOG.

Installatie kan op werkstations 'remote' worden uitgevoerd met parameters /SILENT of /VERYSILENT.

Andere parameters voor de installatiefile zijn:

/NOCANCEL
/NORESTART
/SAVEINF="filename"
/DIR="x:"
/GROUP="folder name"
/NOICONS
/RESTARTEXITCODE=exit code

Aan de uninstaller (unins???.exe) kunnen ook parameters worden meegegeven:

/SILENT, /VERYSILENT
/NORESTART
terug naar start - installatie


Installatie ongedaan maken

De installatie van Teach2000 kan ongedaan worden gemaakt door in het startmenu Teach2000 op te zoeken, en te kiezen voor 'Verwijder Teach2000'.
terug naar start - installatie


Invoeren

De eerste stap is het invoeren. Hier bestaan twee schermen voor, de eenvoudige invoer en de uitgebreide invoer.
De uitgebreide invoer biedt meer mogelijkheden, bijvoorbeeld het definiëren van meerkeuzevragen.
Maak de keuze door op de menubalk een van deze methoden te selecteren.
  • Eenvoudige invoermethode
  • Uitgebreide invoermethode
  • Toevoegen van illustraties/filmpjes
  • Toevoegen van geluidsfragmenten
  • Alternatieve vragen en antwoorden
  • Vertaalhulp
  • Spellingcontrole
  • Vreemde tekens/symbolen en unicode
  • Grieks
  • Fonetische tekens
  • Dubbele vragen verwijderen
  • Lijsten samenvoegen
  • Woordenlijsten delen
Vragenlijsten in het programma krijgen lukt ook door ze te openen. Dit kan vanaf je computer of van internet.
terug naar start


Eenvoudige invoermethode

De eenvoudige invoer is heel flexibel. Voer de woorden in het bovenste scherm in. Begin met het te leren, buitenlandse woord. Typ vervolgens een scheidingsteken en geef daarna de betekenis.

Het scheidingsteken kun je vinden in het omlaagklapbare witte tekstvenster naast 'Lijstscheiding'. Standaard is dit = (is-teken).

Voorbeeld:
one = een
two = twee
three = drie

(Het lijstscheidingsteken is '=')

Als 'one' twee betekenissen heeft, geef je dat zo op:
one = een; 1

Nog meer betekenissen:
one = een; 1; Een

Soms heeft een vraag meerdere schrijfwijzen, geef dit zo op:
one; One = een; 1; Een

Commentaar invoeren?
Gebruik accolades:
vraag = antwoord { En dit is mijn hint, zichtbaar bij overhoren }

Meerkeuzevragen invoeren? Dit is mogelijk in de eenvoudige invoer, maar handiger in de uitgebreide invoer!
Gebruik blokhaken en een asterisk voor het juiste antwoord.
one = [een*][twee][three]

Als je een woordenlijst hebt ingevoerd, klik dan op [Omlaag]. De woorden zullen naar de matrix onderin het scherm worden verplaatst. Nu kun je beginnen met overhoren.

De woorden kunnen, als ze in de 'Definitieve woordenlijst' staan, worden bewerkt door ze te selecteren en op de knop F2 te drukken. Langzaam dubbelklikken voldoet eveneens.

Als bij de vraag of het antwoord in het rood 'meer' staat, betekent dit dat er nog meer mogelijke vragen of antwoorden ingevoerd zijn.
Om deze te bewerken kies met de rechtermuisknop voor 'bewerk alternatieve vragen' of 'bewerk alternatieve antwoorden'.

Sorteren van de lijst kan door op de balk bovenaan de kolom te klikken.

Het is mogelijk met de muis vragen omhoog of omlaag te 'slepen'.

Met het popup-menu van deze lijst (rechter muisknop), kunnen de rijen worden omgeklapt. En er kan worden gezocht naar dubbele invoer. Of om selecties te maken.
terug naar start - invoeren


Uitgebreide invoermethode

De uitgebreide invoermethode heeft, hoe raad je het, meer mogelijkheden dan de eenvoudige. Zo kan commentaar worden opgegeven per item, de vragen en antwoorden kunnen uit meerdere regels bestaan en meerkeuzevragen kunnen worden opgegeven.

Typ in het venster 'vraag' de vraag, bijvoorbeeld 'one'.
Typ in het venster 'antwoord (betekenis)' vervolgens het antwoord, 'een'.
Vul als dat nodig is ook het venster Antwoord 2.

Soms is het handig om een opmerking of hint bij de hand te hebben als je overhoort. Deze hint kun je in het vak 'Extra informatie' kwijt.

Als je klaar bent met invoer klik dan op Save (Post). Of gebruik de toetsencombinatie [CTRL][ENTER].

..en de nieuwe vraag kan worden ingevoerd..

Als de rij wat langer wordt kun je snel navigeren met de schuifbalk.

Gebruik de knop Delete om items te verwijderen.

Het is mogelijk een meerkeuzevraag in te geven. Deze zal bij het overhoren precies worden gevraagd zoals hij is ingegeven. Verander hiervoor bij 'Type vraag' [Normaal] in [Meerkeuzevraag].
De keuzes kunnen bij A t/m F worden ingevoerd.
Het goede antwoord moet vervolgens worden aangevinkt.

Een variatie hierop is de 'Ja/Nee-vraag'. Dit is een meerkeuzevraag met de keuzes 'Ja' en 'Nee'.

Het is mogelijk geluiden aan de vragen te koppelen. Hierdoor krijgt de term overHOREN meer betekenis, en het is goed voor de uitspraak.
Kies hiervoor Toevoegen van gesproken tekst.

Ook kan een vraag worden verduidelijkt met een afbeelding.
Kies hiervoor Toevoegen van illustraties en filmpjes.

Speciaal voor dyslectici is toegevoegd dat woorden een 'label' kunnen hebben. Zo kun je voor een woord aangeven of het mannelijk of vrouwelijk is, of onzijdig. Je kunt met 'Let op!' aangeven dat je bij het overhoren extra moet opletten. Andere mogelijkheden: zelfstandig- en bijvoeglijk naamwoord, werkwoord en uitdrukking.
Deze extra informatie wordt als achtergrondkleur getoond.

Gedeeltes van de vraag kunnen vet, cursief of rood gemaakt worden. Onderstrepen van een vraagdeel dat de aandacht behoeft behoort ook tot de mogelijkheden. Evenals het gebruik van super2+ en subscript voor chemische formules.

Als de vragenlijst is ingevoerd, kun je beginnen met overhoren.
terug naar start - invoeren


Toevoegen van illustraties/filmpjes

Illustraties en animaties kunnen gebruikt worden tijdens de overhoring om de vraag te verduidelijken.

Het toevoegen van illustraties is op twee manieren mogelijk.
Uitgebreide invoer-scherm:
Kies bij een vraag voor [image] (Illustratie). Een dialoogje zal verschijnen.

Eenvoudige invoer-scherm:
Selecteer de kolom 'Illustratie' en druk op de knop met drie puntjes.

De drie icoontjes die dan tot je beschikking staan zijn openen, wissen en toon voorbeeld.

Openen Openen: Zoek het gewenste plaatje op de schijf.

Wissen Wissen: Wis de illustratie uit de vraag. Het bestand zelf zal wel op schijf blijven staan!

Voorbeeld Toon voorbeeld: Laat de illustratie zien.

De formaten die ondersteund worden zijn: JPG, PNG, GIF, BMP, ICO, Windows metafiles en Enhanced metafiles.
Daarnaast kun je verwijzen naar filmpjes/animaties. Kies om deze bestanden te openen "Alle bestanden *.*".

De bestandsnaam zal als absolute naam worden ingevoerd. Dat wil zeggen: 'C:\Mijn Documenten\vraag1.bmp'.
Als de bestandsnaam van de woordenlijst bekend is, kun je ook kiezen voor een 'relatieve' bestandsnaam. Dit is de bestandsnaam t.o.v. de bestandsnaam van de lijst. Voorbeeld: 'vraag1.bmp'.
Als relatieve bestandsnamen worden gebruikt, wordt het eenvoudiger een woordenlijst met illustraties te verplaatsen.
terug naar start - invoeren


Toevoegen van geluidsfragmenten

Geluid kan gebruikt worden tijdens de overhoring om de uitspraak te leren of om de vraag te verduidelijken.

Het toevoegen (openen/inspreken en afspelen) van geluid is op twee manieren mogelijk.

Eenvoudige invoer:
Het openen van een geluid (formaten MP3 en WAV) kan in het eenvoudige invoer-scherm. Selecteer de kolom 'Gesproken tekst' en druk op de knop met drie puntjes.

Uitgebreide invoer:
Als daarnaast ingesproken moet worden, kan dat in het 'uitgebreide invoer'-scherm.
Kies hiervoor bij een vraag voor Geluid (Gesproken tekst). Een dialoogvenster zal verschijnen.

De vier icoontjes die dan tot je beschikking staan zijn openen, wissen, afspelen en opnemen.

Openen Openen: Zoek het gewenste geluidsbestand op de schijf (wav of mp3). Dit kan een bestand zijn dat eerder is ingesproken, eventueel met een ander opname-programma.

Wissen Wissen: Wis de gesproken tekst uit de vraag. Het bestand zelf zal wel op schijf blijven staan!

Afspelen Afspelen: Laat de tekst horen.

Opnemen Opnemen: Spreek zelf teksten in.

De bestandsnaam zal als absolute naam worden ingevoerd. Dat wil zeggen drive\directory\bestandsnaam, bijv. 'C:\Mijn Documenten\vraag1.wav'.
Als de bestandsnaam van de woordenlijst bekend is, kun je ook kiezen voor een 'relatieve' bestandsnaam. Dit is de bestandsnaam t.o.v. de bestandsnaam van de lijst. Voorbeeld: 'vraag1.wav'.
Als relatieve bestandsnamen worden gebruikt, wordt het eenvoudiger een woordenlijst met wav-files te verplaatsen.
terug naar start - invoeren


Alternatieve vragen en antwoorden

Er leiden vele wegen naar Rome. Zo kan het Engelse 'I beg your pardon' vertaald worden met 'Pardon'. Eventueel met als tweede vertaling 'Sorry'.
Helaas zijn deze twee vertalingen niet dekkend. Andere mogelijke vertalingen kunnen worden opgegeven (bijvoorbeeld 'Excuses' of 'Neemt u het mij niet kwalijk').

Andersom, als je Nederlands-Engels overhoort, kan het zijn dat 'Pardon' vertaald kan worden met 'I beg you pardon', maar ook met 'Sorry', enzovoort. Hiervoor zijn mogelijkheden ingebouwd.

In de 'uitgebreide invoer' zijn twee knoppen toegevoegd, 'Alternatieve vragen' en 'Alternatieve antwoorden'.

Als op een van deze knoppen wordt geklikt, verschijnt een schermpje met de invoer voor de alternatieven. Hier kan een grote hoeveelheid alternatieven worden opgegeven. Deze alternatieven worden goedgerekend bij het overhoren.

Als alternatieven zijn opgegeven, is het icoontje van de knop 'gevuld'.

Overhoren

Tijdens een overhoring kan een fout antwoord worden goedgerekend, als het een goed antwoord is, maar net even anders werd geschreven. Het antwoord kan dan worden toegevoegd als synoniem.
terug naar start - invoeren


Vertaalhulp

Alleen voor de 'Full version':

Voor het gemak is een vertaalhulp ingebouwd. Hiermee is het mogelijk een of meer woorden te vertalen naar een van de volgende talen:
  • Nederlands
  • Engels
  • Frans
  • Duits
  • Spaans
  • Portugees
  • Italiaans
  • Zweeds
  • Latijn
  • Swahili
  • Afrikaans
  • Fries
Kies voor de vertaalhulp [Bewerken][Vertaalhulp..].

Selecteer de gewenste brontaal en de taal waar het in vertaald moet worden, voeg te vertalen woorden toe en klik op het pijltje.
Het is mogelijk een reeks woorden in een keer om te zetten.

Als je als bron- en als doeltaal dezelfde taal kiest, is het mogelijk om synoniemen te zoeken.

De woorden in de lijst zijn indicatief, ga niet uit van een altijd vlekkeloze vertaling!
terug naar start - invoeren


Spellingcontrole

Alleen voor de 'Full version':

Voor het gemak is een spellingcontrole ingebouwd. Hiermee is het mogelijk de spelling te controleren van lijsten in de volgende talen:
  • Nederlands
  • Engels
  • Frans
  • Duits
  • Spaans
  • Portugees
  • Italiaans
  • Zweeds
  • Latijn
  • Swahili
  • Afrikaans
  • Fries
Kies voor de spellingcontrole [Bewerken][Spellingcontrole..].

Selecteer de taal van de vragen en de taal van de antwoorden.

De woorden in de lijst zijn indicatief, ga niet uit van een altijd vlekkeloze vertaling! De lijst is ook (verre) van compleet. Woorden die niet worden herkend, maar wel correct zijn, kunnen worden toegevoegd aan de woordenlijst.

De extra woordenlijst wordt opgeslagen in de map 'Application Data' in het profiel van de gebruiker.
Bijvoorbeeld:
C:\Documents and Settings\Gebruikersnaam\Application Data\Basement\FreeSpeech\FreeSpeech_TAAL.dic

De bestanden zijn gewoon tekstbestanden en kunnen met een teksteditor worden gewijzigd.
terug naar start - invoeren


Vreemde tekens/symbolen

Vreemde talen hebben vreemde tekens. Zo is de Duitse Eszett niet op onze toetsenborden te vinden. Ook hebben we een probleem met het omgekeerde vraagteken uit het Spaans, of met de ligatures, de accenten, circumflexes en de cedilles uit het Frans.

Deze en meer vreemde tekens kunnen ingevoerd worden door een scherm, dat op te roepen is door op de symboolknop te klikken, Symbolen. Kies in dit scherm het gewenste symbool.
Eventueel zijn de tekens in dit scherm te wijzigen. Zie hiervoor de paragraaf "Symbolen wijzigen".

Mocht het teken van je keuze er niet tussen staan, kies dan in het menu [Instellingen][Instellingen] bij Functietoetsentoekenning. Hier kunnen letters/woorden achter de F-toetsen worden geprogrammeerd.

Grieks

Voor het invoeren van Grieks kan unicode worden gebruikt, maar voor het gemak is ook een lettertype toegevoegd, Greek.
Zie verder invoeren van Grieks.

Unicode

Japans, Russisch, Arabisch, Chinees, Hebreeuws of andere talen hebben een lettertype waar het Nederlandse toetsenbord niet direct geschikt voor is.

Invoeren van niet-westerse talen wordt in Windows 2000 en XP/Vista ondersteund. Het zogenaamde unicode wordt hiervoor gebruikt, een uitgebreid lettertype. Arial is zo'n unicode-font.

Het invoeren van andere karakters kan als op diverse manieren.

In MS Word kun je een lijst invoeren, de unicode-tekens zijn in te voegen door te kiezen voor [Invoegen][Symbool]. Kies dan het lettertype 'Arial' en de gewenste deelverzameling, bijvoorbeeld Latijn - uitgebreid A.
Zoek het gewenste teken op en kies 'Invoegen'. De tekst kan uit Word vervolgens in Teach2000 worden geplakt.

In Windows 2000, XP en Vista heb je de beschikking over het programma Charmap. Om dit te starten ga je naar [Start][Uitvoeren]. Geef 'charmap' in en klik OK. De 'Character map' wordt nu opgestart.
Kies het lettertype Arial, vink 'Advanced view' aan en kies de gewenste Character set, bijvoorbeeld Windows: Turkish. Selecteer het gewenste teken en kies 'Select'. Met 'Copy' wordt het teken naar het klembord gekopieerd.
Kies in Teach2000 'Plakken' om het klembord naar het invoerscherm te kopiëren.

Kies [Start][Instellingen][Configuratie scherm]. Selecteer Regionale instellingen. Klik op de tab Talen en kies 'Details'. De invoertalen kunnen nu geselecteerd worden. Om talen toe te voegen kun je met 'Toevoegen' een nieuwe taal installeren.
Als je vervolgens Teach2000 opstart en op de taakbalk een andere taal dan EN of DU kiest, bijvoorbeeld EL (Grieks) of TR (Turks), kun je deze taal met het toetsenbord invoeren.

Symbolen wijzigen

De symbolen die worden getoond in het scherm "Symbolen" kunnen worden gewijzigd. Eenvoudig door het bestand 'symbols.txt' uit de installatiemap te wijzigen. Open het bestand in Notepad, breng de veranderingen aan, en sla de wijzigingen op. Teach2000 opnieuw starten en de wijzigingen zullen zichtbaar zijn.
Vier symbolen per regel.
terug naar start - invoeren


Grieks

Het invoeren van een oud-Griekse woordenlijst is eenvoudig:

Bovenin het scherm staan twee lettertype-selectievakken. De eerste is voor de vragen, de tweede voor de antwoorden.

De vragen zijn nu in het Grieks, dus kies voor het eerste vak de karakterset 'Greek'.

Overal in het programma zal het lettertype nu worden aangepast.

Om een beeld te krijgen van welk teken er achter welke toets zit, kies uit het menu [Beeld][Grieks toetsenbord]. Hier wordt het nu beschikbare toetsenbord (azerty of qwerty) getoond.

Wil je het toetsenbord altijd in beeld, kun je het scherm afdrukken ;-)

Het lettertype Greek is niet heel uitgebreid. Daarom is het soms beter om te kiezen voor invoeren in unicode. Zie hiervoor Unicode.
terug naar start - invoeren


Fonetische tekens

Een fonetisch alfabet is een alfabet dat bedoeld is om de uitspraak van woorden eenduidig vast te leggen.
Bron: Wikipedia.

Teach2000 heeft ingebouwde ondersteuning voor het International Phonetic Alphabet (IPA).

Om fonetische tekens in te voegen, kies je in het menu [Beeld][Fonetische tekens]. In dit scherm kan een woord fonetisch worden opgebouwd.
De fonetische tekst kun je als extra commentaar aan de vraag toevoegen. Hiervoor moet het lettertype 'Lucida Sans Unicode' worden gekozen, als antwoordlettertype.

Als je met de muis boven een letter gaat 'hangen', komt er extra informatie over het symbool tevoorschijn.

Na het invoeren van de gewenste symbolen, kun je op 'Kopiëren' klikken, om het gevormde woord naar het klembord te kopiëren. Vervolgens kan de tekst in het venster 'Extra informatie' worden geplakt.

Het is noodzakelijk dat het lettertype Lucida Sans Unicode op de computer is geïnstalleerd. Dit is vrijwel altijd het geval. Mocht het niet zo zijn, is dit gratis font te downloaden.

De scherm-layout is gebaseerd op Phonmap, de Phonemic Script Writer van Jan Mulder, phonmap.com.
terug naar start - invoeren


Dubbele vragen verwijderen

Als je per ongeluk vragen dubbel hebt ingevoerd, kun je deze uit de lijst verwijderen.
Kies hiervoor het rechtermuismenu van de definitieve woordenlijst (eenvoudige invoer).
Selecteer [Zoek naar dubbele woorden].

Eerst worden dubbele vraag/antwoord-combinaties gezocht. Deze kunnen worden gewist.

Dan wordt gezocht naar dezelfde vraag die meerdere keren voorkomt met een ander antwoord.
Bijvoorbeeld:
big = groot
large = groot

Na combineren:
big; large = groot.

Als derde wordt gezocht naar hetzelfde antwoord dat meerdere keren voorkomt voorafgegaan door dezelfde vraag:
chicken = kip
chicken = hen

Na combineren:
chicken = kip; hen

terug naar start - invoeren


Lijsten samenvoegen

Maak de lijsten niet te lang! Hoewel met selecties gewerkt kan worden, wordt toch aangeraden per hoofdstuk/paragraaf een bestand te maken.

De verschillende paragrafen kunnen wel worden samengevoegd, om het geheel te bestuderen.
Om lijsten samen te voegen kies je in het menu [Bestand] voor [Invoegen].

In de lijst met bestanden kun je door de CTRL-toets ingedrukt te houden, meerdere bestanden selecteren. Maar een voor een invoegen lukt ook.
terug naar start - invoeren


Woordenlijsten delen

Via de Teach2000-Homepage kunnen woordenlijsten worden gedeeld. Als je een lijst zoekt is de kans aanwezig dat hij hier te vinden is.

Zelf invoeren is leerzamer. Maar ja, wel minder leuk :-)

Heb je zelf een lijst die je wilt delen, kan je hem inzenden. Dit gaat als volgt:

Ga in het menu naar [Bestand] - [Exporteer lijst naar geheugen]. De lijst staat nu in het geheugen en kan op de site worden gepost.

Dit kan alleen als de definitieve woordenlijst items bevat!

De geposte woordenlijsten kunnen ook via internet worden overhoord: woordjesleren.nl.
terug naar start - invoeren


Overhoren

Het tweede onderdeel van het programma is overhoren.

Direct na het openen van het scherm 'Overhoren' start de overhoring (quiz). Het antwoord kan worden ingevoerd.

De overhoring wordt afgebroken door een instelling te wijzigen, door terug te gaan naar het invoerscherm of als alle vragen zijn beantwoord.
Het is mogelijk even terug te gaan naar het invoerscherm en vervolgens de overhoring te hervatten.
  • Overhoorinstellingen
  • Dit antwoord is wel goed-knop
  • Resultaatgrafiek
  • Uitspraak (Engels)
Bij een foutief antwoord wordt het juiste antwoord getoond, met de verschillen tussen beide (spellingcontrole).
Dit is in kleur:
  • Zwart - De letter van het juiste antwoord komt overeen met die van jouw antwoord.
  • Rood - De letter van het juiste antwoord komt niet overeen met die van jouw antwoord.
  • Groen - De letter ontbreekt in jouw antwoord.
  • Blauw - De letter is teveel in jouw antwoord.
Als je het antwoord niet weet, kun je een hint vragen. Kies hiervoor uit het menu [Help][Hint].
Een gegeven hint gaat af van je bonuspunten, die je kunt verdienen bij een fout antwoord dat toch niet helemaal fout was. Vijf bonuspunten zijn goed voor een extra goed antwoord.

Het resultaat van de overhoring wordt direct in het scherm rechtsonder gegeven. Schuif eventueel iets met de randen om het scherm beter in beeld te krijgen (of om het te verstoppen).

Als een te geven antwoord uit meerdere regels bestaat, en je wilt naar de volgende regel, kies dan [CTRL] + [Enter].

Aan het einde van de overhoring wordt het resultaat, samen met de eventueel eerdere resultaten, in een grafiek getoond.
terug naar start


Overhoorinstellingen

Bovenin het overhoorscherm kan de overhoring ingesteld worden. Hiermee maak je hem makkelijker, of juist moeilijker.
Experimenteer hiermee!
  • Vragenlijst
  • Vraagstelling
  • Volgorde
  • Overhoortype
  • Herhaling
  • Controle
Hoe roder de kleur van het vakje bij het logboek, hoe moeilijker de overhoring. Deze kleur is terug te vinden in de resultaatgrafiek.
terug naar start - overhoren


Overhoorinstelling Vragenlijst

Dit is de selectie van de overhoring. Standaard worden 'Alle vragen' overhoord, maar door de tekst te wijzigen in 'Alleen fouten' kunnen de eerder gemaakte fouten worden overhoord.

De verschillende keuzen uit de vragenlijst zijn:

Alle vragen

Dit is geen selectie. Alle vragen komen voor in de overhoring.

Vragen die eens fout beantwoord zijn

Hiermee worden de moeilijkere vragen verzameld voor de overhoring.

Aangevinkte woorden (selectie)

Vragen die bij het invoeren zijn aangevinkt. Op deze manier is het mogelijk een klein onderdeel uit een grote lijst te oefenen.
Een scherm zal openen met de aanwesige selectie. Om snel deze selectie te wijzigen, kan de spatiebalk gebruikt worden, on combinatie met de omhoog/omlaag-pijltjestoets.

Moeilijke vragen top 10

De tien moeilijkste vragen uit de lijst. Dit aantal kan worden gewijzigd in het instellingenscherm.

Steekproef van 10 vragen

Een toets. Teach2000 selecteert tien willekeurige vragen.

Nieuw toegevoegde vragen

De vragen die nog nooit in een test voorbij zijn gekomen.

Vragen die je al kent weglaten

Vragen die vier keer achter elkaar goed zijn beantwoord worden niet in de toets gestopt.
terug naar start - overhoren - instellingen


Overhoorinstelling Vraagstelling

Geef hier aan of de manier van overhoren 'Engels-Nederlands' (vreemd-bekend) is, 'Nederlands-Engels' (bekend-vreemd) of 'beide'.

Het eenvoudigste is 'vreemd-bekend', het moeilijkst is 'beide'.

Beide

De woorden worden zowel vreemd-bekend als bekend-vreemd overhoord.

Bekend-vreemd zonder commentaar

Bij het leren van woorden is context erg belangrijk (homonymie).

Zo worden vaak de woorden in context (een voorbeeldzinnetje, hyponymie, synonymie of antonymie) gepresenteerd. Dit is vaak ook nodig, omdat je anders niet weet welke betekenis bedoeld wordt (bijv. 'dress' = 'jurk', maar ook 'aankleden').

Het contextzinnetje wordt dan in de extra informatie gezet (bijv. "This is a pretty dress").

Als nu Nederlands-Engels overhoord wordt, is het contextzinnetje direct leesbaar. Daarom is deze instelling bedacht.
terug naar start - overhoren - instellingen


Overhoorinstelling Volgorde

Meestal wil je beginnen met de volgorde zoals de lijst is ingevoerd. Andere mogelijkheden zijn omgekeerd (van achter naar voren) en gehusseld (willekeurige volgorde).
terug naar start - overhoren - instellingen


Overhoorinstelling Overhoortype

Hier wordt de soort overhoring ingesteld. Bijvoorbeeld een meerkeuze-overhoring, of het spel Space Invaders.

Normaal

Geen speciaal type.

Puzzel

Het antwoord is door een gehaktmolen gehaald, en je mag raden wat er bedoeld is.

Meerkeuze

Om te beginnen is het makkelijk een meerkeuze-overhoring te starten. Dan kan je met de muis het juiste antwoord aanklikken. Er zijn twee typen meerkeuzevragen; een die antwoorden zoekt die erg op het juiste antwoord lijken en een die willekeurige antwoorden zoekt.

Oefen lijst zonder typen

Nog eenvoudiger is het eerst te oefenen in gedachten. Dat wordt de vraag getoond en kun je nadenken over het antwoord. Typen hoeft nog niet. Deze wijze heet 'Oefen lijst in gedachten'. Deze oefening kan worden afgebroken door op [Annuleren] te klikken.

Schrijfoefening

Een andere mogelijkheid is 'Dictee'. Bij een dictee wordt het antwoord getoond, waarna je het mag overtypen.

Space Invaders

En probeer het spel Space Invaders eens. Zie Space Invaders.

Methode 'The English Teacher'

Dit is het moeilijkste type. Iedere verkeerde toetsaanslag die niet goed is, wordt afgestraft met een fout antwoord. Op die manier leer je geen verkeerde voorzetsels fout aan.
terug naar start - overhoren - instellingen


Space Invaders

Het doel van Space Invaders is de wereld te redden van de vijandige vragen uit de ruimte. Ze willen je schip binnenvallen. Schakel ze uit door het juiste antwoord snel in te voeren. Je bemanning telt twintig tot de tanden gewapende soldaten en de high-score die wij gehaald hebben was 9660, level 17.

Open het spel door bij het overhoren te kiezen voor 'Overhoortype' 'Space Invaders'.

Het spel zal pas starten als je op de knop 'Play' drukt.

De bemanning bestaat uit twintig leden (20 lives). We beginnen makkelijk, met level 1. Hoe eerder een vraag beantwoord is, hoe hoger de score.

Het spel kan worden afgebroken met de knop 'Exit'. Maar speel het eens uit, als je durft!!

Levels wijzigen

Voeg je eigen levels toe! Of wijzig de bestaande!
Open hiervoor de map C:\Program Files\Teach2000\SpaceShips, en wijzig de JPG-plaatjes. Nieuwe afbeeldingen kunnen gewoon in deze folder worden geplaatst.
Geluidsbestanden (wave) kunnen worden toegevoegd met de zelfde naam als de afbeelding, met daarachter ".wav".
terug naar start - overhoren - instellingen - overhoortype


Overhoorinstelling Herhaling

De lijst kun je herhalen tot je een ons weegt, mits je hier 'Herhaal' aangevinkt hebt. Als je hebt gekozen voor 'Herhaal tot alles goed beantwoord is', kun je ook lang blijven herhalen, maar op een gegeven moment zullen alle woorden goed beantwoord zijn.

Als je kiest voor 'Geen herhaling', zal na afloop van de overhoring toch worden gevraagd of je fouten opnieuw wilt oefenen.

Intervaltraining (Paul Pimsleur)

Een intervaltraining (Spaced repetition) is volgens taalkundigen de beste manier om een woordenlijst te leren.

Dr. Paul Pimsleur heeft hier zijn levenswerk van gemaakt en Teach2000 heeft een vereenvoudigde versie hiervan toegepast (Graduated Interval Recall).
http://en.wikipedia.org/wiki/Pimsleur_language_learning_system

Deze methode berust op het achter elkaar herhalen van de vragen. Als een vraag juist wordt beantwoord, zal hij later terugkomen dan wanneer hij niet juist wordt beantwoord.
Als de vraag vier keer achter elkaar goed wordt beantwoord, zal hij bekend worden geacht en uit de oefening verdwijnen.
terug naar start - overhoren - instellingen


Overhoorinstelling Controle

De controle van het antwoord moet exact de bij het antwoord ingevoerde tekst zijn. Dit is soms lastig. Soms wil je bepaalde hoofdletters of leestekens kunnen negeren. Dit is mogelijk met bovenstaande instelling. Het is ook mogelijk de controle op 'woorden door elkaar gebruikt goed rekenen' in te stellen. Als de vragen zijn genummerd (2. De boom) kan met de optie 'Getallen negeren' in combinatie met 'Leestekenfouten goedrekenen' het vraagnummer worden genegeerd. Een combinatie van de verschillende keuzen is mogelijk.
terug naar start - overhoren - instellingen


Fout antwoord goed rekenen

Bij het overhoren komt het wel eens voor dat het antwoord goed is, maar het toch fout wordt gerekend, omdat het gegeven antwoord niet voorkomt in de lijst. Hier kun je misselijk van worden, maar dat hoeft niet. Voor zo'n dyslexie-foutje bestaat een medicijn.

Als oplossing is de 'ontsnapknop' ingebouwd [image]. Met een druk op deze knop is het mogelijk het laatstgegeven antwoord goed te rekenen.

Vervolgens is het mogelijk het gegeven antwoord als mogelijk goed antwoord (synoniem) toe te voegen, zodat het de volgende keer wel in een keer goed wordt gerekend.
terug naar start - overhoren


Resultaatgrafiek

Na een overhoring wordt het resultaat in een grafiek getoond.
De laatste vijftien scores worden onthouden en getoond, van links naar rechts.

Eventueel kan commentaar aan het resultaat worden toegevoegd, dat zichtbaar gemaakt kan worden door op de balk in de grafiek te klikken.

De balken hebben een kleurvariatie van geel tot rood, waar geel eenvoudig is, en rood moeilijk. Een tien bij een gele balk kan makkelijker te halen zijn dan een vijf bij een rode balk.

De moeilijkheidsgraad is bij het instellen van de overhoring zichtbaar in het blokje bij het logboek.
terug naar start - overhoren


Gesproken tekst (computer)

Spraak kan worden gebruikt om de uitspraak van een woord of zin te leren.
Maar verwacht er niet te veel van. De text-to-speech-technologie die hiervoor wordt gebruikt produceert geen natuurlijke spraak. De stem klinkt als de blikken robot van een ouderwetse science fiction.

Zet spraak aan of uit in het menu met [Instellingen][Spraak]. Een welkomstzin zal worden uitgesproken.

Het is leuk er eens mee te experimenteren. Windows XP en Vista zijn standaard uitgerust met spraaktechnologie Engels. Frans en Duits kunnen niet met deze Engelse stem worden uitgesproken. Download hiervoor anderstalige text-to-speech engines.

Voor oudere versies van Windows zal de Speech API 5.1 zelf gedownload en geïnstalleerd moeten worden: speechsdk51.exe.

Zie voor meer informatie:
Microsoft: http://www.microsoft.com/speech

Om op je computer de instellingen voor spraak in te stellen, ga je in het Control Panel naar 'Speech'.

Zelf inspreken van teksten?
Geluid invoegen
terug naar start - overhoren


Afdrukken

De vragenlijst kan op verschillende manieren wordt geprint. Kies hiervoor in het menu [Bestand][Afdrukken].
  • Toets
  • Spiekbrief
  • Overhoorkaartjes

terug naar start


Afdrukken toets

Voor de docenten kan het handig zijn een woordenlijst als proefwerk te printen.

Met name als meerdere versies van dezelfde overhoring nodig zijn om spieken te voorkomen.

Stap 1

Definieer de vragen. Dit kunnen open vragen zijn, maar ook meerkeuzevragen zijn geschikt. De meerkeuze- (of ja/nee-)vragen worden ingevoerd in de 'uitgebreide invoer'-mode.

Stap 2

Kies in het menu voor [Bestand][Afdrukken][Proefwerk].
Voer de benodigde gegevens in. Gegevens gemarkeerd met een sterretje (*) zijn verplicht.
Het is mogelijk een schoollogo op te geven.

Stap 3

Pas eventueel het aantal witregels aan onder een vraag. Of wijzig het aantal punten dat voor de vraag wordt toegekend. Met het andere-muisknop-menu is het mogelijk alle punten en alle witregels in een keer te wijzigen.
Bij een meerkeuzevraag kan worden aangegeven of de antwoorden ook moeten worden geschud. Zo worden de versies werkelijk verschillend.

Stap 4

Kies 'Husselen' om de vragen te schudden.

Stap 5

Kies voor 'Afdrukken'. De 'code' zal wijzigen. Herhaal stap 4 voor een nieuwe versie. Tip:
Boven de pagina's wordt de nummering weergegeven (Page 1 of 4). Onderaan, in de voettekst, wordt de bestandsnaam en de datum weergegeven (file://C:\etc.).
Dit is de instelling van Internet Explorer. Hier kan Teach2000 niets aan veranderen.
Om dit te voorkomen, kies in Internet Explorer [Bestand][Pagina instelling] of [File][Page Setup].
De pagina-instellingen worden nu getoond.
Bij de koptekst (header) staat '&w&bPage &p of &P'. Maak dit veld leeg.
Bij de voettekst (footer) staat '&u&b&d'. Maak dit veld ook leeg.
Geef [OK] en de instelling is gewijzigd.
terug naar start - afdrukken


Afdrukken spiekbrief

Voor de leerlingen kan het handig zijn een woordenlijst als spiekbrief te printen.
Vooral als ze Teach2000 niet lang genoeg gebruikt hebben.

Het is volstrekt illegaal een spiekbriefje te gebruiken bij een overhoring.
Daarom is het met Teach2000 niet mogelijk ook maar iets wat op een spiekbriefje lijkt af te drukken.
Ook niet via [Bestand][Afdrukken][Spiekbrief], dus dat hoeven jullie niet te proberen.
terug naar start - afdrukken


Afdrukken overhoorkaartjes

Overhoorkaartjes zijn kaartjes die kunnen worden gebruikt om rijtjes te leren, zonder computer.

Het is mogelijk deze kaartjes af te drukken met Teach2000, vanuit het menu [Bestand][Afdrukken][Overhoorkaartjes].

Het papier dat dan uit de printer komt, moet worden dubbelgevouwen in de lengte (grijze lijn), met de tekst naar de buitenkant. Plak de twee delen met lijm aan elkaar.

Met een schaar kunnen de verschillende overhoorkaartjes worden losgeknipt, op de stippellijn.

Nu is het mogelijk om bijvoorbeeld in de trein te oefenen. Vragen die je al kent kun je op een aparte stapel leggen.
terug naar start - afdrukken


Gevorderd gebruik

Voor de gevorderde Teach2000-gebruikers de volgende onderwerpen.
  • Importeren
  • Exporteren
  • Instellingen
  • Wrts
  • Bestanden openen vanaf een website
  • Een nieuwe taal toevoegen
  • Backup bestanden
  • Versleuteling van bestanden
  • Multimedia embedden
  • Teach2000 online - woordjesleren.nl
  • Wist je dat..

terug naar start


Importeren

Vragenlijsten kunnen vanuit MS Word en MS Excel worden geïmporteerd in Teach2000, door ze gewoon te plakken in de eenvoudige invoer.
Op deze manier is het ook mogelijk lijsten in te scannen (OCR) en ze naar Teach over te hevelen.

Wist je dat de woordenlijsten gemaakt in het programma 'Overhoor' geopend konden worden in Teach2000?
Evenals o.a. de bestanden van 'Overhoor Jezelf 95', 'Practise with Charlie', 'Vocabularium', 'KVocTrain' en de 'Himalsoft Dictionary'?

Bovengenoemde en andere software is te vinden op het internet:

Overhoor (Efka Soft)
KVocTrain
Overhoor Jezelf 95 (ABC-EDUCA)
Practise with Charlie (ABC-EDUCA)
Vocabularium
BackPack
Vocatout
Himalsoft Dictionary
Overhoor Platinum
Overhoringsprogramma Talen

terug naar start - gevorderd gebruik


Exporteren

Wist je dat woordenlijsten eenvoudig kunnen worden geëxporteerd naar een Excel-file, of naar comma-separated-value (csv)-formaat? Zodat ze kunnen worden bewerkt door andere applicaties?

Kies hiervoor [Bestand][Opslaan als]. En kies dan Excel- of csv-file.

Een andere vorm van exporteren is 'naar geheugen'. Kies hiervoor [Bestand][Exporteer lijst naar geheugen].
De lijst kan nu vanuit het klembord in bijvoorbeeld MS Word, of WinToets (De Rode Planeet) worden geplakt.

Zie ook Exporteren als website.
terug naar start - gevorderd gebruik


Website genereren

Ook een overhoring op je site? Maak dan van je woordenlijst een on-line oefening!
Kies hiervoor in het menu voor [Bewerken], [Genereer internetpagina].

Er zijn verschillende overhoringen om uit te kiezen.

De overhoring zoals ook op de website van Teach2000 wordt gebruikt, of een schuifoefening.
Ook kun je kiezen voor een site met een link en een voorbeeld.

Geef de website een titel en vul de andere velden in, als je wilt.

Onderin kun je een lay-out voor de pagina kiezen.

Om de site op te slaan, kies je voor 'Genereren'.

Vervolgens moet de html-pagina op de website worden gezet. Dit heet uploaden.
Gebruik hier bijvoorbeeld het gratis FileZilla voor.

Voor webdesigners: Een eigen lay-out ontwerpen?

Dit kan door een nieuwe cascading style sheet (css) te maken, of die van je website te gebruiken.
Zet dit bestand in de map C:\Program Files\Teach2000\HTML Templates

Dan zal de lay-out verschijnen in het lijstje.

Ondersteuning voor Unicode

De optie 'PHP UTF8-header toevoegen' is toegevoegd om in de header van de pagina aan te geven dat het een UTF8-bestand is. Voorwaarde is wel dat php gebruikt kan worden op de webserver en dat de file de php-extensie krijgt.
<?php
header("Content-Type:text/html;charset=utf-8");
?>

Meestal is de encoding iso-8859-1 (HTTP 1.1-default). Beter is het echter om de standaard encoding te wijzigen in UTF8.

Link:
www.w3.org/International/O-HTTP-charset
terug naar start - gevorderd gebruik - exporteren


Instellingen

Veel opties van Teach2000 zijn instelbaar met eigen voorkeuren, zoals de taal van het programma.
Open het instellingenscherm via het menu met [Instellingen][Instellingen].

Een scherm wordt zichtbaar, met vier categorieën.

Algemeen
Bewerken
Overhoren
Geavanceerd

Algemeen

Taal van het programma: Stel hier de taal van het programma in.

Het is mogelijk dat Teach2000 een keer per week bij opstarten het internet opgaat om te controleren of een nieuwe versie beschikbaar is. Zet dit aan of uit bij 'Automatisch periodiek controleren op een nieuwe versie'.
Nu controleren: Controleer of een nieuwe versie beschikbaar is.

Functietoetsentoekenning: Programmeer de codes achter de functietoetsen.

Bewerken

Maak backups van overschreven lijsten in de prullenbak: Bij het opslaan van bestanden wordt de vorige versie overschreven. Het is mogelijk de vorige versie terug te halen, door het bestand uit de prullenbak te halen. Soms is het niet wenselijk dat bestanden naar in prullenbak gaan, inplaats van te verdwijnen. Dan kan deze optie worden uitgezet. Zie ook Backup-bestanden.

Onthoud de laatst geopende map: Als Teach2000 opnieuw wordt gestart, kan de map waarin het laatst is gewerkt, wederom de actieve locatie worden.

Invoegen: Toon bronbestand in Extra informatie: Bij invoegen van lijsten kan de naam van het originele bestand worden toegevoegd als Extra informatie.

Aantal bestanden in lijst 'Laatst geopend': Het aantal recent geopende bestanden is hier in te stellen, van 0 t/m 10.

Overhoren

Tijd juiste antwoord in beeld: Bij een fout antwoord wordt het goede antwoord even getoond. Stel hier in hoelang dat is. Het is mogelijk een tijd van 0 seconden op te geven.

Bij een leeg antwoord de vraag vooruitschuiven: Als je het antwoord niet weet, kun je bij een leeg antwoord de vraag even doorschuiven, om hem later in de oefening te beantwoorden.

Vraagnummer tonen: Bij het overhoren kan het nummer van de vraag in de lijst getoond worden.

Logboek tonen: Het logboek toont de vragen met antwoorden. Soms is dit niet gewenst, omdat dit 'afkijken' in de hand werkt. Met deze instelling kan het logboek worden verborgen.
Individuele kolommen kunnen ook worden verborgen. Dit kan niet in het instellingenscherm, maar in het overhoorscherm. Klik hiervoor met de rechtermuisknop op de titel van de kolom. Een menu wordt zichtbaar met alle kolommen. Kies de kolom die verborgen moet worden.

Zelfgekozen geluid bij een antwoord: Het standaard geluid bij een antwoord zat? Gebruik je eigen geluid!

Aantal vragen in 'Top 10 probleemvragen': Het aantal vragen dat bij de gelijknamige overhoorinstelling vragenlijst in de oefening moet worden gestopt.

Normering: Het percentage antwoorden dat goed beantwoord moet worden om tot een voldoende te leiden. Sommige leerwegen passen de 60%-norm toe, anderen de 80%-norm.

Geavanceerd

Bestandsassociaties: Bij de installatie worden Teach2000 (.t2k) en Overhoorlijsten (.ohw/.oh4) gekoppeld aan Teach2000. Klikken op zo'n bestand zal Teach2000 openen, met de lijst waarop geklikt werd.
Hier is deze associatie met Teach2000 te wijzigen.
terug naar start - gevorderd gebruik


Wrts

Wrts is net als Teach2000 een overhoorprogramma, maar dan via internet. Dit heeft als voordeel dat je op iedere computer met internet kunt oefenen, en dat je altijd je lijsten hebt.

Teach2000 heeft als voordeel dat er veel meer mee mogelijk is.

Met de Wrts-koppeling worden de voordelen van Wrts met de voordelen van Teach2000 gecombineerd.

Op iedere computer met Teach2000 kun je inloggen in Wrts, om je lijsten te bewerken, nieuwe lijsten toe te voegen en om lijsten te oefenen.

Wrts is onderdeel van De Digitale School. De Digitale School ondersteunt onderwijsprojecten, waaronder ook Teach2000, met hosting.

Wat je nodig hebt

Om gebruikt te maken van deze combinatie heb je naast Teach2000 nodig:
Een (gratis) registratie op Wrts.nl,

De inloggegevens moeten worden ingevuld in het Wrts-scherm, [Bestand][Wrts].
Als je de computer niet deelt met anderen, of als je een eigen account hebt, kun je aangeven dat de inloggegevens mogen worden opgeslagen. Zo hoef je ze niet iedere keer in te vullen.

Om te zien welke lijsten je hebt opgeslagen kies je 'Ophalen'.

Een lijst openen in Teach2000 kan met de knop 'Openen'. Het scherm zal sluiten en de lijst is zichtbaar in het invoerscherm bij de eenvoudige invoer.

Een lijst opslaan in Wrts?

Open de lijst in Teach2000, kies in het menu [Bestand][Wrts] en druk op 'Opslaan'.
Geef een naam op en de talen, en de lijst zal in het overzicht verschijnen.

Let op! Wrts ondersteunt geen afbeeldingen, scores, of andere eigenschappen die in Teach2000 aan een vraag zijn te koppelen. Bewaar dus de overhoorbestanden van Teach2000 gewoon op je computer en zie deze opslagmogelijkheid niet als een vervanging.

Voor de techneuten: staat de computer in een netwerk met een proxy?

Dan werkt de koppeling niet zondermeer. Eerst zal de proxy-server moeten worden opgegeven. Kies voor 'Proxy-instellingen configureren'.
terug naar start - gevorderd gebruik


Bestanden openen vanaf een website

Let op, dit hoofdstuk is alleen geschikt voor html-programmeurs en andere computertechneuten!

Teach2000-bestanden kunnen worden geopend vanaf een website met het url-protocol "t2kp".

Lijsten op internet

Maak de verwijzing naar een Teach-bestand vanaf een website als volgt:

Link: <a href="t2kp://www.teach2000.nl/Woordenlijst.t2k">woordenlijst</a>

Let op! Het volledige (absolute) domein moet in de href worden opgegeven! En bij een sub-domein ook nog "http":

Link: <a href="t2kp://http://lijsten.teach2000.nl/Woordenlijst.t2k">woordenlijst</a>

Om dit te laten werken moet het URL-protocol t2kp geregistreerd zijn. Dit gebeurt automatisch bij de installatie van Teach2000 vanaf versie 7.52. En voor lijsten op internet moet Teach2000 toegang hebben tot het internet om de woordenlijst te downloaden.

Een andere manier van publiceren

Lijsten kunnen ook als formulier worden gepubliceerd. De lijst kan eerst nog worden bewerkt:

In code is dit:

<form action="http://www.woordjesleren.nl/test.php" method="POST">
<textarea name="list_plain" rows="10" cols="60" name="list" wrap="off">
les douze mois = de twaalf maanden { Eventueel commentaar voor de hint }
janvier = januari
février = februari
mars = maart
avril = april
mai = mei
juin = juni
juillet = juli
août = augustus
septembre = september
octobre = oktober
novembre = november
décembre = december
</textarea>
<br>
<input type="submit" value="Overhoor">
</form>

Lijsten op intranet

Een verwijzing naar een bestand op een logische drive ziet er dan anders uit, als onderstaande html-code:

Link: <a href="t2kp://C:\Program Files\Teach2000\Voorbeelden\Woordenlijst.t2k">woordenlijst</a>

Als op de link de hier gedefinieerd is, wordt geklikt, zal het bestand geopend worden in het overhoorprogramma.

Omdat het niet altijd mogelijk is het volledige pad in de link te zetten, kan de verwijzing ook alleen de naam van de woordenlijst bevatten:

Link: <a href="t2kp://Woordenlijst.t2k">woordenlijst</a>

Om het bestand te kunnen openen moet het pad wel bekend zijn. Hiervoor is een registry-sectie beschikbaar,

HKEY_CURRENT_USER\Software\Teach2000\T2KP_Paths

De eerste 'String Value' die hier aangetroffen wordt, die samen met het in de url opgegeven bestand een geldige bestandsnaam vormt, zal worden gebruikt om het bestand te openen.

Linken vanaf een CD/DVD

Als het, bijvoorbeeld bij bestanden op een CD/DVD, niet mogelijk is de drive-letter bij de verwijzing in te sluiten, kan de link als volgt worden gepubliceerd:

Link: <a href="t2kp://teach_files\Woordenlijst.t2k">woordenlijst</a>

Teach2000 zal dan alle geïnstalleerde drives (van Z:\ tot A:\) aflopen, tot het bestand is gevonden.
De eerste combinatie die wordt geprobeerd is:
Z:\teach_files\Woordenlijst.t2k
Dan de volgende combinatie:
Y:\teach_files\Woordenlijst.t2k
En zo voort.

Dialoog

Mocht Teach2000 aangeroepen zijn met het protocol t2kp, en het bestand kan niet met een van de bovenstaande methoden worden gevonden, wordt een dialoog getoond waarmee naar een directory kan worden gezocht.
terug naar start - gevorderd gebruik


Een nieuwe taal toevoegen

Teach2000 is er in een Nederlandse, een Engelse en een Duitse versie.
Een eigen (aangepaste) vertaling van Teach2000 is mogelijk.

Alle tekst die je tegenkomt in Teach2000 staat in de file ml_dutch.txt. Deze file kan worden bewerkt om een nieuwe taal te creëren.

Dit kan handig door deze file te openen met Notepad, en te wijzigen.
De codes %s of %d betekenen dat er tekst wordt tussengevoegd. Ook kan het een regeleinde betekenen. %s staat voor tekst en %d voor een nummer.

Een nieuwe taal toevoegen

  1. Maak een kopie van ml_dutch.txt.
  2. Noem het ml_jouwtaal.txt, waarbij jouwtaal de gewenste taal is.
  3. Vul onder [LANGUAGE] de taal in, bijvoorbeeld '&Spanish', dit wordt in het taalkeuze-menu getoond.
  4. Het '&'-teken geeft de focustoets weer, het karakter erna zal worden onderstreept.
    Met het toetsenbord is dan te navigeren (Alt + onderstreepte letter).
    Probeer zoveel mogelijk de &-tekens voor dezelfde letters te laten als het Nederlandse bestand.
    Dit houdt de toetsenbordnavigatie eenduidig. Maar geen ramp als het niet lukt.
    Omdat met de onderstreepte letter wordt genavigeerd, moet de onderstreepte letter in ieder scherm uniek zijn.
    Dit geldt ook voor het menu. In submenu's kan de onderstreepte letter opnieuw gebruikt worden.
    Microsoft Office heeft als voorbeeld gediend voor de applicatie. Met name bij het menu heeft Office de voorkeur bij vertaling en navigatie.
  5. Vertaal dan alle andere teksten.

Segmenten

  • [DIALOG_HEADERS] de headers van een dialoog.
  • [DIALOG_CAPTIONS] de teksten van de knoppen op een dialoog.
  • [TEXTS] alle regels die een gebruiker tijdens het uitvoeren voorgeschoteld kan krijgen.
  • [CAPTIONS] alle tekst die in de windows te vinden is.
  • [PRACTISE_HINTS] de opmerkingen die gegeven worden om de gebruiker het antwoord duidelijk te maken.
  • [SCORES] de scores die aan puntenpercentages worden toegekend.
  • [INTERFACE_LAYOUT] de invoertype-combobox.
  • [INTERFACE_QUESTIONTYPE] de vraagtype-combobox/uitgebreide invoerscherm.
  • [LABELS] de labels die als kleur aan een vraag kunnen worden gehangen/uitgebreide invoerscherm.
  • [TESTTYPE] de vraagtype-combobox/uitgebreide invoerscherm.
  • [INTERFACE_PRACTISELIST] de vragenlijst-combobox/overhoorscherm.
  • [INTERFACE_PRACTISEMODE] de vraagstelling-combobox/overhoorscherm.
  • [INTERFACE_PRACTISEORDER] de volgorde-combobox/overhoorscherm.
  • [INTERFACE_PRACTISEKIND] de overhoortype-combobox/overhoorscherm.
  • [INTERFACE_PRACTISEREPEATING] de herhaling-combobox/overhoorscherm.
  • [INTERFACE_PRACTISECHECKTYPE] de controle-combobox/overhoorscherm.
  • [HINTS] de extra uitleg die wordt gegeven als met de muis over bepaalde programma-onderdelen wordt bewogen. Deze hints zijn in tweeën gedeeld door een pipe, het eerste deel is de balloon hint, het tweede te tekst die getoond wordt in de statusbalk.
  • [TIPS_OF_THE_DAY] de tips van de dag, gegroepeerd.
  • [INTERFACE_TIP_OF_THE_DAY] de keuze wel of niet tonen van de tip van de dag.
  • [LANGUAGES] de talen uit het woordenboek die worden gebruikt bij vertalingen en spellingscontrole.
  • [HTML_EXPORT] de parameters die in de te exporteren html worden gezet.
Commentaar wordt aangeduid met ';'.

Als de vertaling gereed is, kan hij natuurlijk naar ons verzonden worden, indien goedgekeurd stoppen we hem dan als nieuwe taal in de installer.
Eeuwige roem, maar voornamelijk dank van vele gebruikers zal je deel zijn...

Bij een nieuwe versie kunnen teksten toegevoegd worden. Hier zal dit met commentaar worden vermeld, zoek dan in dit bestand bijvoorbeeld naar:

; *** Nieuwe items versie 8.16

terug naar start - gevorderd gebruik


Backup bestanden

Bij het opslaan van een bestand wordt het oude bestand overschreven, maar eerst wordt de oude versie naar de prullenbak (Recycle Bin) verplaatst. Alle oude versies worden bewaard. En om ze permanent te wissen, leeg gewoon de prullenbak!

MS Word e.a. zouden ook zo moeten omgaan met de oude versies..

Zo is het document in geval van nood nog terug te halen.

Backup naar de prullenbak kan worden uitgezet. Het is een instelling.
terug naar start - gevorderd gebruik


Versleuteling van bestanden

Vragenlijsten kunnen worden versleuteld. Op deze manier kan de inhoud worden beschermd.
Versleutelde lijsten kunnen alleen worden geopend met een wachtwoord.
Eenmaal geopend kunnen ze niet onversleuteld worden opgeslagen.

Dit is handig voor bijvoorbeeld een overhoring.

Zie voor een voorbeeld van een versleutelde lijst uit de voorbeeldenmap het bestand:

Hoofdsteden (Versleuteld, wachtwoord=geheim).t2k
Het wachtwoord van deze lijst is "geheim".

Ook bestanden versleuteld opslaan? Neem contact op voor meer informatie.
terug naar start - gevorderd gebruik


Multimedia embedden

Het is mogelijk om de multimedia-bestanden, waar normaliter een verwijzing naar bestaat, in te voegen in de vragenlijst zelf.
Hierdoor wordt het mogelijk lijsten met afbeeldingen en geluidsbestanden op een website te publiceren, zonder te werken met foutgevoelige zip-bestanden.

Zie voor een voorbeeld van een lijst met ingebedde afbeeldingen uit de voorbeeldenmap het bestand:

Hoofdsteden (Ingebedde afbeeldingen).t2k

Ook multimedia embedden? Neem contact op voor meer informatie.
terug naar start - gevorderd gebruik


Teach2000 online - woordjesleren.nl

Woordjesleren.nl is de online-versie van Teach2000. Hiermee is het mogelijk voor een proefwerk nog even snel te oefenen, op een computer zonder Teach2000.
Lijsten kunnen worden geopend, bewerkt, overhoord en weer worden opgeslagen.
Of geprint als spiekbrief. Ssssst.

woordjesleren.nl
terug naar start - gevorderd gebruik


Wist je dat..

Wist je dat..
  • lijsten samengevoegd kunnen worden? Via [Bestand][Invoegen]?
  • de instellingen van het programma zijn te verwijderen door de installatie van Teach2000 ongedaan te maken?
  • als je een website-adres invult als commentaar (extra informatie) bij een vraag, je kunt klikken op deze link en je dan naar dat internetadres toegaat?
  • als je commentaar (extra informatie) invoegt na de tekens /*, je dit commentaar niet ziet bij overhoren? Zo kun je bijvoorbeeld de oorsprong van de vraag administreren.
    Voorbeeld eenvoudige invoer:
    table = tafel { Dit commentaar is zichtbaar /* Dit gedeelte niet! }
  • bij een antwoord van meerdere regels je de nieuwe regel kunt beginnen door de toetscombinatie [CTRL][Enter]?
  • er een aanzienlijke verzameling woordenlijsten is te downloaden op de website van Teach2000? En dat deze woordenlijsten ook via internet te overhoren zijn?
  • Teach2000 volgens onderzoek beter is dan Overhoor?
  • Malmberg Teach2000 gebruikt voor de methodes Of Course, Na Klar en Worldwide?

Handige sneltoetsen:

  • F1: De meest handige sneltoets voor ieder scherm - help.
  • CTRL-E: Antwoord goedrekenen.
  • CTRL-M: Vraag even overslaan.
  • CTRL-S: Opslaan.
  • CTRL-O: Openen.
  • CTRL-P: Afdrukken.
  • CTRL-C: Kopiëren.
  • CTRL-V: Plakken.
  • CTRL-X: Knippen.
  • [CTRL][Enter]: Meerregelig antwoord invoeren.

Parameters:

  • opstarten met de parameter -ns voorkomt dat het splash-screen wordt getoond?
  • opstarten met de parameter -Business Teach2000 tot een zakelijke studieomgeving maakt? Zonder plaatjes en zonder geluiden.
  • opstarten met de parameter -nh voorkomt dat de gele uitlegballonnetjes worden getoond?
  • de parameter -nh een volkomen zinloze optie is?
  • opstarten met de parameter -Help of -? hulp verzorgt bij de verschillende mogelijke parameters?
  • bij opstarten van de installatie met de parameter -LOG een logbestand wordt gemaakt met alle tijdens het installeren gedane acties?
  • het mogelijk is een parameter mee te geven door in Windows te kiezen voor [Start][Uitvoeren] en dan bijvoorbeeld 'teach2000 -First' in te geven.
  • de website een forum heeft waar je al je vragen over Teach2000 kunt stellen?

terug naar start - gevorderd gebruik


Bestandsformaat

De vragenlijsten worden opgeslagen in XML-formaat. Dit is een standaard, open formaat, zodat andere applicaties de documenten kunnen inlezen en ook hier hun lijsten in kunnen opslaan.

<teach2000> - Root node, hier staat alles in
<version>817</version> - Versie
<description>Normal</description> - Normale woordenlijst (het enige type tot nu toe)
<message_data mm_files_embedded="0" encrypted="0"> - Multimedia is niet ingevoegd, maar externe verwijzingen, de lijst in niet versleuteld
<font_question>Arial</font_question> - Het lettertype van de vraag
<font_answer>Arial</font_answer> - Lettertype antwoord
<items> - Begin van de reeks vragen
<item id="0"> - Eerste vraag
<rf>0</rf> - Geen opmaak in de vraag
<question>one</question> - Vraag
<answer_type>0</answer_type> - Het antwoordtype, 0=normaal, 1=meerkeuze, 2=meerkeuze met meer antwoorden mogelijk
<answer>een</answer> - Antwoord
<errors>3</errors> - Aantal keer fout beantwoord
<testcount>23</testcount> - Aantal keer overhoord
<sel>-1</sel> - Aangevinkt
<is_multiplechoice>N</is_multiplechoice> - Deze vraag is geen meerkeuzevraag
</item>
...
</items>
<testresults> - De oefenresultaten voor de grafiek
<testresult>
<score>10</score> - Een tien!
<diff>80</diff> - De moeilijkheidsgraad
<comment></comment> - Geen commentaar toegevoegd
<dt>2006-09-04T19:24:20.906</dt> - Wanneer de toets gemaakt werd
<duration>1899-12-30T00:01:11.406</duration> - Hoe lang de toets duurde
<answerscorrect>10</answerscorrect> - Aantal juiste antwoorden
<wrongonce>0</wrongonce>
<wrongtwice>0</wrongtwice>
<wrongmorethantwice>0</wrongmorethantwice>
</testresult>
...
</testresults>
</message_data>
</teach2000>

Opmaak kan ook worden toegevoegd aan de vragen. En meerkeuzevragen kunnen worden gedefiniëerd:

<item id="0">
<rf>-1</rf> - Het gaat hier om een vraag met opmaak
<question>"vr"&lt;b&gt;"aa"&lt;/b&gt;"g"</question> - De vraag in html, tags b, i, u, red/def, sub of sup
<qlbl>4</qlbl> - Label 4, let op!
<tt>1</tt> - Testtype 1, overhoor alleen bekend-vreemd
<alt_questions>vraag 2
vraag 3</alt_questions> - De synoniemen van de vraag, gescheiden door line breaks
<answer_type>0</answer_type> - Het antwoordtype, 0=normaal, 1=meerkeuze, 2=meerkeuze met meer antwoorden mogelijk
<answer>antwoord</answer> - Het antwoord, kan regeleinden bevatten
<second_answer>Antwoord 2</second_answer> - Synoniem van het antwoord, kan ook regeleinden bevatten
<alt_answers>antwoord 3
antwoord 4
antwoord 5
etc.</alt_answers> - Meer synoniemen van het antwoord
<remarks>Extra informatie</remarks> - Extra informatie
<errors>0</errors> - Nooit fout beantwoord
<testcount>2</testcount> - Twee keer overhoord
<soundfile>C:\My Documents\Geluid.mp3</soundfile> - Het bijbehorende geluidsbestand
<picturefile>C:\My Documents\Afbeelding.png</picturefile> - De bijbehorende afbeelding
<is_multiplechoice>N</is_multiplechoice> - Geen meerkeuze
</item>
<item id="1">
<rf>0</rf> - Geen opmaak
<question>meerkeuzevraag</question> - Vraag
<answer_type>1</answer_type> - Het antwoordtype, 0=normaal, 1=meerkeuze, 2=meerkeuze met meer antwoorden mogelijk
<mc_answers>
<mc_answer id="A ok="Y">antwoord a (juiste antwoord)</mc_answer> - Optie 1
<mc_answer id="B ok="N">antwoord b</mc_answer> - Optie 2
<mc_answer id="C ok="N">antwoord c</mc_answer> - Optie 3
</mc_answers>
<errors>0</errors> - Nooit fout beantwoord
<testcount>0</testcount> - Nooit overhoord
</item>
<item id="2">
<rf>0</rf> - Geen opmaak
<question>meerkeuzevraag (meerdere antwoorden mogelijk)</question> - Vraag
<answer_type>2</answer_type> - Het antwoordtype, 0=normaal, 1=meerkeuze, 2=meerkeuze met meer antwoorden mogelijk
<mc_answers>
<mc_answer id="A ok="Y">antwoord a (juiste antwoord)</mc_answer> - Optie 1
<mc_answer id="B ok="N">antwoord b</mc_answer> - Optie 2
<mc_answer id="C ok="Y">antwoord c (eveneens juist)</mc_answer> - Optie 3
</mc_answers>
<errors>0</errors> - Nooit fout beantwoord
<testcount>0</testcount> - Nooit overhoord
</item>

Voor versie 8.17 bestond answer_type niet, het meerkeuze-formaat was als volgt:

<answer>A</answer> - Antwoord A is het juiste antwoord
<is_multiplechoice>Y</is_multiplechoice> - Meerkeuzevraag
<mc_answers>
<mc_answer id="A">antwoord a (juiste antwoord)</mc_answer> - Optie 1
<mc_answer id="B">antwoord b</mc_answer> - Optie 2
<mc_answer id="C">antwoord c</mc_answer> - Optie 3
</mc_answers>

terug naar start - gevorderd gebruik


Index

Teach2000-help

Dit is de helptekst van het overhoorprogramma Teach2000.

Updates, een handleiding, voorbeelden en meer is te vinden op de website van Teach2000.

Inhoud:
  • De installatie van Teach2000
  • Invoeren
  • Overhoren
  • Afdrukken
  • Gevorderd gebruik

Vragen? Commentaar? Opmerkingen? Laat van je horen op het forum van Teach2000.
copyright © 1997-2007 basement.nl / bas groot
basement.nl aanvaardt geen aansprakelijkheid voor mogelijke directe en indirecte schade voortvloeiend uit het gebruik van de aangeboden software